
Network Analyst Tutorial

Copyright © 1995-2010 Esri All rights reserved.



Table of Contents
About the ArcGIS Network Analyst tutorial   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   . 3

Exercise 1: Creating a network dataset   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   . 4

Exercise 2: Creating a multimodal network dataset   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   . 13

Exercise 3: Finding the best route using a network dataset   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   . 26

Exercise 4: Finding the closest fire stations   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   . 34

Exercise 5: Calculating service areas and creating an OD cost matrix   .   .   .   .   .   .   .   .   .   .   .   .   .   . 42

Exercise 6: Creating a model for route analysis   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   . 59

Exercise 7: Servicing a set of orders with a fleet of vehicles   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   . 69

Exercise 8: Finding best routes to service paired orders   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   . 89

Exercise 9: Choosing optimal store locations using location-allocation   .   .   .   .   .   .   .   .   .   .   .   .   . 105

Network Analyst Tutorial

Copyright © 1995-2010 Esri. All rights reserved. 2



About the ArcGIS Network Analyst tutorial
The ArcGIS Network Analyst extension allows you to build a network dataset and perform analyses on a
network dataset. The best way to learn Network Analyst is to use it. In the exercises in this tutorial, you will do
the following:

• Use ArcCatalog to create and build a network dataset from feature classes stored within a
geodatabase.

• Define connectivity rules and network attributes for the network dataset.

• Perform various network analyses in ArcMap using the Network Analyst toolbar.

• Learn how to use the Network Analyst geoprocessing tools to create models that automate analyses.

To use this tutorial, you need to have ArcGIS installed with the Network Analyst extension and have the
tutorial data installed on a local or shared network drive on your system.

Tutorial data

Ask your system administrator for the correct path to the tutorial data if you do not find it at the default
installation path (C:\ArcGIS\ArcTutor\Network Analyst\Tutorial).

In this tutorial

• Exercise 1: Creating a network dataset

• Exercise 2: Creating a multimodal network dataset

• Exercise 3: Finding the best route using a network dataset

• Exercise 4: Finding the closest fire stations

• Exercise 5: Calculating service area and creating an OD cost matrix

• Exercise 6: Creating a model for route analysis

• Exercise 7: Servicing a set of orders with a fleet of vehicles

• Exercise 8: Finding best routes to service a set of paired orders

• Exercise 9: Choosing optimal store sites using location-allocation
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Exercise 1: Creating a network dataset
In this exercise, you will create a network dataset in a geodatabase using
San Francisco street and turn features. You will also include historical traffic
data so you can solve time-dependent routes.

Creating a network dataset

Steps:

1. Start ArcCatalog by clicking Start > All Programs > ArcGIS
> ArcCatalog 10.

2. Enable the Network Analyst extension.
a. Click Customize > Extensions.

The Extensions dialog box opens.

b. Check Network Analyst.

c. Click Close.

3. On the Standard toolbar, click the Connect To Folder button .
The Connect to Folder dialog box opens.

4. Navigate to the folder with the ArcGIS Network Analyst tutorial data.
The default location for the tutorial data is C:\ArcGIS\ArcTutor\Network Analyst\Tutorial

5. Click OK.
A shortcut to the folder is added to the Catalog Tree under Folder Connections.

6. In the Catalog Tree, expand ...\ArcTutor\Network Analyst\Tutorial > Exercise01 >
SanFrancisco.gdb.

7. Click the Transportation feature dataset.
The feature classes the feature dataset contains are listed on the Contents tab of ArcCatalog.

8. Right-click the Transportation feature dataset and click New > Network Dataset.

Complexity:
Beginner

Data Requirement:
ArcGIS Tutorial Data Setup

Data Path:
C:\ArcGIS\ArcTutor\Network
Analyst\Tutorial\Exercise01

Goal:
To create a network dataset from a
streets feature class in a geodatabase

Network Analyst Tutorial

Copyright © 1995-2010 Esri. All rights reserved. 4



The New Network Dataset wizard opens.

Note: To open the New Network Dataset wizard in a geodatabase, you
right-click the feature dataset that contains the source feature
classes (Streets, for example) and choose New > Network
Dataset. For a shapefile-based network dataset, you right-click the
Streets shapefile itself—not the workspace that contains the
shapefile—and choose New > Network Dataset.
The reason for the difference is that geodatabase networks allow
you to use multiple sources that are stored in the feature dataset
to create a multimodal network, while shapefile-based network
datasets are only capable of handling a single source feature
class.

9. Type Streets_ND for the name of the network dataset.

10. Click Next.

11. Check the Streets feature class to use it as a source for the network dataset.
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12. Click Next.

13. Click Yes to model turns in the network.

14. Check <Global Turns>, which enables you to add default turn penalties, and check
RestrictedTurns to select it as a turn feature source.

15. Click Next.

16. Click Connectivity.
The Connectivity dialog box opens. Here you can set up the connectivity model for the
network.

For this Streets feature class, all streets connect to each other at endpoints.

17. Make sure that the connectivity policy of Streets is set to End Point.

18. Click OK to return to the New Network Dataset wizard.

19. Click Next.

20. This dataset has elevation fields, so make sure that the Using Elevation Fields option is
chosen.
Elevation settings in a network dataset further defines connectivity. To understand why,
assume two edges have coincident endpoints in X and Y space but have different elevations
(one endpoint is higher than the other). Furthermore, assume their connectivity policy is set to
Endpoint. If elevation is ignored, the edges connect. However, if elevation is considered, they
won't connect.

There are two ways to model elevations: using true elevation values from geometry or using
logical elevation values from elevation fields.

The Streets feature class has logical elevation values stored as integers in the F_ELEV and
T_ELEV fields. If two coincident endpoints have field elevation values of 1, for example, the
edges will connect. However, if one endpoint has a value of 1, and the other coincident
endpoint has a value of 0 (zero), the edges won't connect. ArcGIS Network Analyst recognizes
the field names in this dataset and automatically maps them, as shown in the graphic below.
(Only integer fields can serve as elevation fields.)
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21. Click Next.

You can configure historical traffic data with this page of the wizard. Traffic data enables you to
find the quickest routes based on time and day of the week. For example, the quickest route
from point A to point B at 8:30 a.m. on Wednesday (during rush hour) could be different than
the quickest route between the same points at 1:00 p.m. on Sunday. Even if the path of the
route is the same, the time it takes to reach the destination could vary.

Learn more about historical traffic data

The SanFrancisco geodatabase contains two tables that store historical traffic data:
DailyProfiles and Streets_DailyProfiles. The schemata of the tables were designed in such a
way that Network Analyst could recognize the role of each table and configure historical traffic
automatically.

22. Click Next.
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The page for setting network attributes is displayed.

Network attributes are properties of the network that control navigation. Common examples are
cost attributes that function as impedances over the network and restriction attributes that
prohibit traversal in both directions or one direction, like one-way roads.

ArcGIS Network Analyst analyzes the source feature class (or classes) and looks for common
fields like Meters, Minutes (FT_Minutes and TF_Minutes, one for each direction), and Oneway.
If it finds these fields, it automatically creates the corresponding network attributes and assigns
the respective fields to them. (This can be viewed by clicking Evaluators.)

Network Analyst automatically sets up eight attributes for this San Francisco data:
HierarchyMultiNet, Meters, Minutes, Oneway, RoadClass, TravelTime,
WeekdayFallbackTravelTime, and WeekendFallbackTravelTime. It also assigns evaluators to
the attributes.

23. Click the Meters row to select it, then click Evaluators to examine how the values of network
attributes are determined.
The Evaluators dialog box opens.
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The table on the Source Values tab lists the source feature classes. Linear source feature
classes, which become edge elements in the network dataset, are listed twice; once for the
from–to direction and once for the to–from direction. (The directions are in relation to the
digitized direction of the source line feature.) The Type column shows the type of evaluator
used to calculate the network attribute values. The Value column holds information the
evaluator needs to calculate attribute values.

24. From the Attribute drop-down list, click each type of attribute, one at a time, and inspect the
evaluator types and values for the source feature classes.

25. Click OK to return to the New Network Dataset wizard.

In the next steps, you will add a new attribute to restrict movement over the turn elements
created from the RestrictedTurns feature class.

26. Click Add.
The Add New Attribute dialog box opens.

27. Type RestrictedTurns in the Name field.

28. For Usage Type, choose Restriction.

Note that Use by Default is checked. This restriction will be used by default when a new
network analysis layer is created. If you want to ignore the restriction when performing an
analysis, you can disable it in the settings of the analysis.

29. Click OK.
The new attribute, RestrictedTurns, is added to the list of attributes. The blue circle with the D
in the middle indicates the attribute is enabled by default in new analyses.

30. Click Evaluators to assign values by source to the new attribute.

31. Follow these substeps to set the type of evaluator for RestrictedTurns to Constant with a value
of Restricted.

a. Click the Attribute drop-down list and choose RestrictedTurns.

b. For the RestrictedTurns row, click under the Type column and choose Constant
from the drop-down list.

c. Click the Value column and choose Restricted.
The result should look like the following graphic:
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The evaluators for the street sources are empty, so they will remain traversable when this
restriction is used.

32. Click OK to return to the New Network Dataset wizard.

33. Right-click the HierarchyMultiNet row and choose Use By Default.
The blue symbol is removed from the attribute. This means the hierarchy won't be used by
default when an analysis layer is created with this network dataset.

34. Click Next.

35. Click Yes to set up directions.

36. Click Directions.
The Network Directions Properties dialog box opens.

Now you will specify the fields used to report directions for network analysis results.

37. On the General tab, make sure that the Name field for the Primary row automatically mapped
to NAME.
The NAME field contains the San Francisco street names, which are needed to help generate
driving directions.

The result should look like the following graphic:
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38. Click OK to return to the New Network Dataset wizard.

39. Click Next.
A summary of all the settings is displayed for your review.

40. Click Finish.

A progress bar opens showing you that Network Analyst is creating the network dataset.

Once the network is created, the system asks if you want to build it. The build process
determines which network elements are connected and populates the attributes of the network
dataset. You must build the network before you can perform any network analysis on it.

41. Click Yes.
The Build Network Dataset progress bar opens; it will disappear when the build process is
finished.
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The new network dataset, Streets_ND, is added to ArcCatalog along with the system junctions
feature class, Streets_ND_Junctions.

42. Preview the network dataset by clicking its name and clicking the Preview tab.

43. Close ArcCatalog.

Now you can add the network dataset to ArcMap and use it to create network analysis layers.
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Exercise 2: Creating a multimodal network dataset
Exercise 1 shows how to create a network for a single mode of
transportation; however, travelers and commuters frequently use several
modes of transportation, such as walking on sidewalks, driving on road
networks, and riding on trains. Goods also travel on many modes of
transportation like trains, ships, trucks, and airplanes. In this exercise, you
create a multimodal network dataset from multiple feature classes within a
feature dataset.

Starting the New Network Dataset wizard

Steps:

1. Start ArcCatalog by clicking Start > All Programs > ArcGIS > ArcCatalog 10.

2. Enable the Network Analyst extension.
a. Click Customize > Extensions.

The Extensions dialog box opens.

b. Check Network Analyst.

c. Click Close.

3. If you don't already have a connection to the Network Analyst Tutorial folder, you need to
create one by following the substeps below.

a. On the Standard toolbar, click the Connect To Folder button .
The Connect to Folder dialog box opens.

b. Navigate to the folder with the ArcGIS Network Analyst tutorial data.
The default location for the tutorial data is C:\ArcGIS\ArcTutor\Network
Analyst\Tutorial

c. Click OK.
A shortcut to the folder is added to the Catalog Tree under Folder Connections.

4. In the Catalog Tree, expand ...\ArcTutor\Network Analyst\Tutorial > Exercise02 >
Paris.gdb.

5. Click the Transportation feature dataset.
The feature classes it contains are listed on the Contents tab of ArcCatalog.

6. Right-click the Transportation feature dataset and click New > Network Dataset.

Complexity:
Beginner

Data Requirement:
ArcGIS Tutorial Data Setup

Data Path:
C:\ArcGIS\ArcTutor\Network
Analyst\Tutorial\Exercise02

Goal:
Create a multimodal network dataset
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The New Network Dataset wizard opens.

Naming the network and selecting source feature classes

Steps:

1. Type ParisMultimodal_ND as the name of your network dataset.

2. Click Next.
The wizard page for choosing the feature classes that participate in the network dataset is
displayed.

3. Click Select All to select all the feature classes to participate as sources in the network.
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4. Click Next.

5. Click Yes to model turns in the network.
Although there are not any turn feature classes for this network, selecting Yes allows the
network dataset to support global turns and gives you the option of adding turn features
anytime after the network is created.

6. Click Next.
The page for setting connectivity is displayed.

Setting the connectivity and elevation policies

Connectivity in ArcGIS Network Analyst begins with the definition of connectivity groups. Each edge
source is assigned to exactly one connectivity group, and each junction source can be assigned to one or
more connectivity groups. A connectivity group can contain any number of sources. How network
elements connect depends on which connectivity groups the elements are in. For example, two edges
created from two distinct source feature classes can connect if they are in the same connectivity group. If
they are in separate connectivity groups, the edges won't connect unless they are joined by a junction that
participates in both connectivity groups.
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You will create connectivity groups in the following steps.

Steps:

1. Click Connectivity to set up the connectivity model for the network.
The Connectivity dialog box opens.

2. Click the Group Columns up-arrow once to increase the number of connectivity groups to 2.
A column for the second connectivity group is created in the Connectivity Groups table.

Connectivity group 1 represents the metro system, and group 2 represents the street network.

3. Click the Streets row and check the check box under the column labeled 2 to move the
Streets source to connectivity group 2.

4. Click the Metro_Entrances row and check the check box under the column labeled 2 to
include the source feature class in groups 1 and 2.
Metro entrances are points of transfer between the streets and the walkways that lead to the
metro stations.

Each feature of Metro_Entrances is coincident with a vertex of the streets feature class.
However, the streets feature class has a policy of endpoint connectivity. Since the metro
entrances need to be connected to the streets at the coincident vertex, you must set
Metro_Entrances to override the default endpoint connectivity of the streets.

5. Change the Connectivity Policy of the Metro_Entrances row from Honor to Override.

6. Click OK to return to the New Network Dataset wizard.

7. Click Next.

Elevation settings in a network dataset further defines connectivity. To understand why, assume
two edges have coincident endpoints in X and Y space but have different elevations (one
endpoint is higher than the other). Furthermore, assume their connectivity policy is set to
Endpoint. If elevation is ignored, the edges connect. However, if elevation is considered, they
won't connect.

There are two ways to model elevations: using true elevation values from geometry or using
logical elevation values from elevation fields.

8. No elevation data exists for this dataset; therefore, click None.
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9. Click Next.
The wizard displays the attributes of the network dataset.

Removing an attribute

Network attributes are properties of the network that control navigation. Common examples are cost
attributes that function as impedances over the network and restriction attributes that prohibit traversal in
both directions or one direction, like one-way roads.

ArcGIS Network Analyst analyzes the source feature class (or classes) and looks for common fields like
Meters, Minutes (FT_Minutes and TF_Minutes, one for each direction), and Oneway. If it finds these fields, it
automatically creates the corresponding network attributes and assigns the respective fields to them. (This
can be viewed by clicking Evaluators.)

Network Analyst automatically configures five attributes for the Paris streets data: HierarchyNavStreets,
Meters, Minutes, Oneway, and Road Class.
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Although you could leave the hierarchy attribute on the network dataset, this short set of steps demonstrates
how to remove a network attribute by removing HierarchyNavStreets.

Steps:

1. Click HierarchyNavStreets.

2. Click Remove.
Now the network is left with four attributes.

Verifying and creating network attributes

One goal for this network dataset is to model both pedestrian times and drive times. When performing
analyses on the network, this allows you to choose between the two time costs. For example, you can
choose to answer a question like, What's the quickest route from point A to point B for a pedestrian who
can walk along streets and ride the metro? or What's the quickest route for someone who's driving a car?
To accomplish this, you must set up two time-cost attributes: PedestrianTime and DriveTime.

Steps:

The Minutes attribute that Network Analyst automatically detected in the source data represents
drive times, so you can change the name to something more appropriate.

1. Select the Minutes row, click Rename, type DriveTime, and press ENTER.

Next, you will create the PedestrianTime attribute.

2. Click Add.
The Add New Attribute dialog box opens.

3. Type PedestrianTime in the Name text box.

4. Set the Usage Type to Cost.

5. Change Units to Minutes.

6. Set the Data Type to Double.

7. Click OK.
The Add New Attribute dialog box closes, and PedestrianTime is added to the list of
attributes.
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The three cost attributes—Meters, DriveTime, and PedestrianTime—have yellow warning
symbols that alert you to potential problems with the evaluators, which specify how the values
of network attributes are calculated.

In the next three sections, you will configure the evaluators.

Configuring the Meters evaluator

You will set up various evaluators in this section and the following sections. The Meters evaluator
calculates the distance cost for edges in the network.

Steps:

1. Select Meters and click Evaluators.

The Evaluators dialog box opens. Here you can view and edit the evaluator type and its value
for each source in the network. You can see that junction and turn sources always have one
associated evaluator, but edge sources have two: one for each direction of travel (the from-to
and to-from directions).

ArcGIS Network Analyst inspects all source feature classes and tries to automatically assign
evaluators for the Meters attribute. In this case, it discovered that the Metro_Lines and Streets
sources had a field named Meters, so it set up evaluators to pull values from those fields. The
same length values are assigned to the from-to and to-from directions of the edge sources.

Network Analyst was unable to find fields for meters in the Transfer_Stations and
Transfer_Street_Station sources. Hence, a warning symbol is present to indicate there is a
potential problem.

2. While holding the SHIFT key, click the Transfer_Stations From-To row and click the
Transfer_Street_Station To-From row.
The four rows with the warning symbols are selected.

3. Right-click any of the selected rows and click Type > Field.

Network Analyst Tutorial

Copyright © 1995-2010 Esri. All rights reserved. 19



The warning symbols change to red error symbols, which indicate an incomplete assignment
of values for the field evaluator.

4. With the four rows still selected, right-click any one of them and click Value >
SHAPE_LENGTH.

This assigns values from the SHAPE_LENGTH field in the selected source feature classes to
the Meters attribute for their associated network edge elements.

5. Click Apply.
The Meters network attribute is configured to get length values. For the network elements
created from Metro_Lines, Streets, Transfer_Stations, and Transfer_Street_Station sources,
the attribute values are respectively pulled from their Meters, METERS, Shape_Length, and
SHAPE_LENGTH fields.

Configuring the DriveTime and Oneway evaluators

Since automobiles only travel on streets, the evaluators for the various sources should be set up
accordingly.

Steps:

1. From the Attribute drop-down list, choose DriveTime.
The DriveTime values for the Streets source have been populated automatically by Network
Analyst; however, the other edge sources display warning symbols because they don't have
values assigned. These sources need to be marked as restricted. Also, metro stations need to
be restricted so that new network analysis objects can be prevented from locating there.
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2. Make sure that all the rows with a warning symbol (Metro_Lines, Transfer_Stations, and
Transfer_Street_Station) are selected.
If they aren't selected, select them by clicking one row and holding the CTRL key while clicking
the other rows.

3. Hold the CTRL key and click Metro_Stations to add it to the selection.

4. Right-click any one of the selected rows and click Type > Constant.

The same rows remain selected, and their evaluator type changes to Constant.

5. Again, right-click one of the selected rows, but this time click Value > Properties.
The Constant Value input box appears.

6. Type -1 and press ENTER.

The values for all the selected rows change to -1. Network Analyst treats any elements that
have a cost value of -1 as restricted. So whenever the DriveTime attribute is used as
impedance in network analyses, these sources are not traversable.

7. Click Apply.

The Oneway attribute is loosely associated with the DriveTime attribute because it models the
one-way traffic restrictions that drivers are required to follow. Later, when you perform an
analysis using DriveTime as the cost, you should enable the Oneway restriction so the resulting
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routes respect one-way streets. Alternatively, when modeling the movement of a pedestrian,
you shouldn't use the Oneway restriction, since pedestrians are free to walk in the direction they
choose.

8. From the Attribute drop-down list at the top of the Evaluators dialog box, choose Oneway.
The Attribute Values frame now displays the evaluators for the Oneway network attribute,
which has automatically been assigned values for the Streets source.

The sources related to the metro system don't need one-way restrictions.

9. Click either one of the Streets rows and click the Evaluator Properties button .
You can see the expression used to determine whether a street is one-way.

10. Click Cancel to return to the Evaluators dialog box.

Configuring the PedestrianTime evaluator

The PedestrianTime network attribute represents the time it takes a pedestrian to travel on the network. In
this set of steps, you will assign appropriate travel times for a pedestrian who can ride the metro system
or walk along streets.

Steps:

1. From the Attribute drop-down list at the top of the Evaluators dialog box, choose
PedestrianTime.
The rows for the following sources should already be selected: Metro_Lines,
Transfer_Stations, and Transfer_Street_Station.

2. Right-click one of the selected rows and click Type > Field.

3. Again, right-click one of the selected rows, but this time click Value > TRANSITTIM.
The TRANSITTIM fields store the time costs for a pedestrian to use the transit system. The
streets also need pedestrian time values, but you calculate them differently.

4. Click the Streets From-To row to select it. Hold the CTRL key and click the Streets To-From
row to select both rows.
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5. Right-click one of the selected rows and click Value > Properties.
The Field Evaluators dialog box opens.

For the Streets source, the value of PedestrianTime is the walk time. Assuming a pedestrian
can walk at 3 km/hour, walk time in minutes would be [Meters] * 60 / 3000 where [Meters] is the
attribute containing the length of the edge in meters.

6. Double-click the field METERS to move it into the Value = text box and finish typing the
expression as [METERS] * 60 / 3000 in the Field Evaluators dialog box, as shown below.

7. Click Verify to ensure that the expression is correct and fix it if necessary.

8. Click OK to return to the Evaluators dialog box.

9. Click OK to return to the New Network Dataset wizard.

10. Click Next.
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Configuring directions

When routes are calculated on your network dataset, you have the ability to produce driving directions to
accompany the results. A network dataset is required to have at least one edge source with a text
attribute (for street name information) and a distance attribute to show how far it will be before the next
relevant maneuver is required.

Steps:

1. Click Yes to set up directions.

2. Click Directions.
The Network Directions Properties dialog box opens.

Now you will specify the fields used to report directions for network analysis results.

3. On the General tab, click the Source drop-down list and choose Streets.

4. In the Street Name Fields list, click Primary to select it.

5. Click in the Name column and choose FULL NAME.

6. Click OK to return to the New Network Dataset wizard.

7. Click Next.
A summary of all the settings is displayed for your review.
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Creating and building the network dataset

After setting up how you want the network dataset to function, you need to create and build it. The
creation process is quick and essentially creates a container for the logical network.

Steps:

1. Click Finish.
A progress bar opens showing you that Network Analyst is creating the network dataset.

Once the network is created, the system asks if you want to build it. The build process
determines which network elements are connected and populates the attributes of the network
dataset. You must build the network before you can perform any network analysis on it.

2. Click Yes.
The Build Network Dataset progress bar opens; it will disappear when the build process is
finished.

The new network dataset, ParisMultimodal_ND, is added to ArcCatalog along with the system
junctions feature class, ParisMultimodal_ND_Junctions.

3. Preview the network dataset by clicking its name and clicking the Preview tab.

4. Close ArcCatalog.
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Exercise 3: Finding the best route using a network
dataset
In this exercise, you will find the quickest route to visit a set of stops in a
predetermined order.

Preparing your display

Steps:

1. If you have Exercise03.mxd open in ArcMap, skip to step 6.

2. Start ArcMap by clicking Start > All Programs > ArcGIS >
ArcMap 10.

3. On the ArcMap - Getting Started dialog box, click Existing Maps > Browse for more.
The Open ArcMap Document dialog box appears.

4. Browse to C:\ArcGIS\ArcTutor\Network Analyst\Tutorial.
This is the default installation location for the tutorial data.

5. Double-click Exercise03.mxd.
The map document opens in ArcMap.

6. Enable the Network Analyst extension.
a. Click Customize > Extensions.

The Extensions dialog box opens.

b. Check Network Analyst.

c. Click Close.

If the Network Analyst toolbar is not displayed, you need to add it.

7. Click Customize > Toolbars > Network Analyst.
The Network Analyst toolbar is added to ArcMap.

If the Network Analyst window is not displayed, you need to add it.

8. On the Network Analyst toolbar, click the Show/Hide Network Analyst Window button .
The dockable Network Analyst window opens.

You can dock or undock the Network Analyst window. In this exercise, it is docked below the
Table Of Contents window.

Complexity:
Beginner

Data Requirement:
ArcGIS Tutorial Data Setup

Data Path:
C:\ArcGIS\ArcTutor\Network
Analyst\Tutorial

Goal:
Find the quickest route (shortest path)
between stops.
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Creating a route analysis layer

Steps:

1. Click Network Analyst on the Network Analyst toolbar and click New Route.

The route analysis layer is added to the Network Analyst window. The network analysis
classes (Stops, Routes, Point Barriers, Line Barriers, and Polygon Barriers) are empty.

The analysis layer is also added to the Table Of Contents window.

Adding a stop

Next, you will add the stops to be visited by a route.

Steps:
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1. In the Network Analyst window, click Stops (0).
Stops is selected, which means it is the active network analysis class.

2. On the Network Analyst toolbar, click the Create Network Location Tool .
By clicking on the map with the Create Network Location Tool, you can add network analysis
objects to the active network analysis class.

3. Click anywhere on the street network to define a new stop location.

ArcGIS Network Analyst calculates the nearest network location and symbolizes the stop with
the Located symbol. The stop remains selected until another stop is placed or you clear the
selection.

The located stop also displays the number 1. All stops have a unique number, which
represents the order in which the stop will be visited by the route. Also notice that the Stops
class in the Network Analyst window now lists one stop.

4. Add two more stops anywhere on or near the streets.

The new stops are numbered 2 and 3.

The first stop is treated as the origin, and the last as the destination.

The sequence of the stops can be changed by clicking a stop in the Network Analyst window
and dragging it to another position in the list.

If a stop is not located on the network, it appears with an unlocated symbol. (However, using
the default settings, you would need to place a stop more than 5 kilometers from the nearest
street segment for it to not locate.)
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You can move an unlocated stop closer to the network to locate it. If a stop is located on the
network but in the wrong location, you can move the stop to the correct position.

5. To move a stop, follow these substeps:
a. Click the Select/Move Network Locations Tool on the Network Analyst toolbar.

b. Click a stop to select it.

c. Click the stop again and drag it to a new location.

Setting up the parameters for the analysis

Next, you will specify that your route will be calculated based on travel time (minutes), that U-turns are
allowed anywhere, and that one-way and turn restrictions must be followed.

Steps:

1. Click the Analysis Layer Properties button on the Network Analyst window.

The Layer Properties dialog box opens.

2. Click the Analysis Settings tab.

3. Make sure that Impedance is set to TravelTime (Minutes).

This network dataset has historical traffic data associated with the TravelTime (Minutes)
attribute. If you choose to enter a start time by checking Use Start Time and filling out the three
fields below it, Network Analyst will find the quickest route based on that time of day and
historical traffic speeds. Alternatively, it will find the quickest route based on a function of street
lengths and speed limits.

4. Check Use Start Time, enter a specific time and date or day of the week.
a. For Time of Day, enter the time you want to leave the first stop.

b. Click either Day of Week or Specific Date.
If you choose Day of Week, specify any day between Sunday and Saturday;
optionally, choose Today to use your system's current day setting.

If you choose Specific Date, either type a date in the text box or click the down-arrow
to open a calendar that allows you to choose a date.

5. Leave Use Time Windows unchecked.
You can specify time windows for stops and have ArcGIS Network Analyst try to find a route
that honors those time ranges in which a stop should be visited.

6. Leave Reorder Stops To Find Optimal Route unchecked.
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By leaving this property unchecked, Network Analyst discovers the best route given the stop
sequence you specify. This is commonly known as the traveling salesman problem (TSP). If
checked, it finds the best route and best sequence to visit the stops.

7. Click the U-Turns at Junctions drop-down arrow and choose Allowed.

8. Click the Output Shape Type drop-down arrow and choose True Shape with Measures.

9. Make sure that the Use Hierarchy and Ignore Invalid Locations boxes are checked.

10. In the Restrictions frame, make sure that RestrictedTurns and Oneway are checked.

11. In the Directions frame, make sure that Distance Units is set to Miles, Use Time Attribute is
checked, and the time attribute is set to TravelTime (Minutes).

The Analysis Settings tab should look like the following graphic; however, your Use Start
Time properties may be different:

12. Click OK.

Computing the best route

Steps:

1. Click the Solve button on the Network Analyst toolbar.
A route feature appears in the map display and in the Network Analyst window under the
Routes class.
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If a warning message appears, a stop may be located on a restricted edge. Try moving one or
more stops using the Select/Move Network Locations Tool , which is on the Network
Analyst toolbar.

2. Click the Directions Window button on the Network Analyst toolbar.
The Directions dialog box opens.

3. On the rightmost column of the Directions dialog box, click one of the links named Map.
An inset map of the maneuver is displayed.

4. Click Close.

Adding a barrier

In this section, you will add a barrier on the route to represent a roadblock, and you will find an alternate
route to your destination.

Steps:

1. Click Windows > Magnifier.
The Magnifier window opens.

2. Click the title bar of the Magnifier window and drag the window to reposition it over the route.

Network Analyst Tutorial

Copyright © 1995-2010 Esri. All rights reserved. 31



3. In the Network Analyst window under Point Barriers (0), click Restriction (0) .

4. Click the Create Network Location Tool on the Network Analyst toolbar.

5. In the Magnifier window, click anywhere on the route to place one or more barriers.

Tip: To see where a barrier will be placed, hold down the 1 key before
clicking on the map with the Create Network Location Tool.

6. Click the Solve button on the Network Analyst toolbar.
A new, alternative route is computed that avoids the barrier.

7. Close the Magnifier window.
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Saving the route

The route analysis layer is currently stored in memory, so if you exit ArcMap without saving, the analysis
is lost. However, if you save the map document, the analysis layer is saved with it. You can also export
data. One option is to export the entire analysis layer to an LYR file. The analysis properties and objects
are stored within the LYR file. Another option is to save the sublayers of the analysis as feature classes
using the Export Data command. The next set of steps show how to export the Routes sublayer to a
feature class.

Steps:

1. On the Network Analyst window, right-click Routes (1) and click Export Data.

The Export Data dialog box opens.

2. In the Output feature class text box, type or browse to a location to save the results in, such
as C:\ArcGIS\ArcTutor\Network
Analyst\Tutorial\SanFrancisco.gdb\Exercise3_Route.

3. Click OK.
The route's feature is saved to the specified workspace.

4. Click No when prompted to add the exported data to the map as a layer.

5. If you don't plan to work on any other exercise, exit ArcMap. Click No to discard any changes.

6. If you plan to work on another exercise, follow the substeps below.
a. Click File > New.

The New Document dialog box opens.

b. Click OK.

c. Click No when prompted to save changes.
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Exercise 4: Finding the closest fire stations
In this exercise, you will find the four fire stations that can provide the
quickest response to a fire at a given address. You will also generate routes
and driving directions for the firefighters to follow.

Preparing your display

Steps:

1. If you have Exercise04.mxd open in ArcMap, skip to step 6.

2. Start ArcMap by clicking Start > All Programs > ArcGIS > ArcMap 10.

3. On the ArcMap - Getting Started dialog box, click Existing Maps > Browse for more.

4. Browse to C:\ArcGIS\ArcTutor\Network Analyst\Tutorial.
This is the default installation location for the tutorial data.

5. Double-click Exercise04.mxd.
The map document opens in ArcMap.

6. Enable the Network Analyst extension.
a. Click Customize > Extensions.

The Extensions dialog box opens.

b. Check Network Analyst.

c. Click Close.

If the Network Analyst toolbar is not displayed, you need to add it.

7. Click Customize > Toolbars > Network Analyst.
The Network Analyst toolbar is added to ArcMap.

If the Network Analyst window is not displayed, you need to add it.

8. On the Network Analyst toolbar, click the Show/Hide Network Analyst Window button .
The dockable Network Analyst window opens.

You can dock or undock the Network Analyst window. In this exercise, it is docked below the
Table Of Contents window.

Complexity:
Beginner

Data Requirement:
ArcGIS Tutorial Data Setup

Data Path:
C:\ArcGIS\ArcTutor\Network
Analyst\Tutorial

Goal:
Create, set up, and solve a closest facility
analysis.
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Creating the closest facility analysis layer

Steps:

1. Click Network Analyst on the Network Analyst toolbar and click New Closest Facility.

The closest facility analysis layer is added to the Network Analyst window. The network
analysis classes (Facilities, Incidents, Routes, Point Barriers, Line Barriers, and Polygon
Barriers) are empty.

The analysis layer is also added to the Table Of Contents window.

Adding facilities

Next, you will load facilities from a point feature layer that represents fire stations.
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Steps:

1. In the Network Analyst window, right-click Facilities (0) and click Load Locations.

The Load Locations dialog box opens.

2. Choose FireStations from the Load From drop-down list.

3. Click OK.
Forty-three fire stations are displayed in the map as facilities and listed in the Network
Analyst window.
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Adding an incident

Next, you will add an incident by geocoding an address received from an emergency call.

Steps:

1. In the Network Analyst window, right-click Incidents (0) and choose Find Address.
The Find dialog box opens.

2. Make sure that SanFranciscoLocator is chosen in the Choose a locator drop-down list.

3. In the Street or Intersection text box, enter 1202 Twin Peaks Blvd.

4. Click Find.
One location is found with that street address and is listed as a row in the table at the bottom
of the Find dialog box.

5. Right-click the row and choose Add as Network Analysis Object.
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This adds the located address as an incident, which you can see on the map and in the
Network Analyst window.

6. Close the Find dialog box.

Setting up parameters for the analysis

Next, you will specify the parameters for your closest facility analysis.

Steps:

1. Click the Analysis Layer Properties button on the Network Analyst window.

The Layer Properties dialog box opens.

2. Click the Analysis Settings tab.

3. Make sure that Impedance is set to TravelTime (Minutes).

4. Enter 3 in the Default Cutoff Value text box.
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ArcGIS will search for fire stations that are within three minutes of the fire on Twin Peaks
Boulevard. Any fire stations outside the cutoff time are ignored.

5. Increase Facilities to Find to 4.
ArcGIS will search for a maximum of four fire stations from the fire site. However, the three-
minute cutoff still applies; therefore, if only three fire stations are within the three-minute cutoff,
then a fourth fire station will not be found.

6. Choose Facility to Incident for the Travel From direction.
The search results emanate out from the fire stations, which are loaded as facilities. This
mimics the fire engines traveling from the stations to the fire (incident).

7. Click the U-Turns at Junctions drop-down arrow and choose Allowed.

8. Click the Output Shape Type drop-down arrow and choose True Shape with Measures.

9. Uncheck Use Hierarchy.

10. Check Ignore Invalid Locations.

11. In the Restrictions frame, uncheck RestrictedTurns.
Fire engines don't need to obey this traffic rule in emergencies.

12. In the Directions frame, make sure that Distance Units is set to Miles, Use Time Attribute is
checked, and the time attribute is set to TravelTime (Minutes).

Your Analysis Settings tab should look like the following graphic:

13. Click OK.

Identifying the closest facilities

Steps:

1. Click the Solve button on the Network Analyst toolbar.
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Routes appear in the map display and in the Route class in the Network Analyst window.

Note that you configured the analysis to find four facilities within a three-minute cutoff;
however, only three facilities are within the cutoff.

2. Click the Directions Window button on the Network Analyst toolbar.
The Directions dialog box opens.

Driving directions from each fire station are listed in the window.

3. If you don't plan to work on any other exercise, exit ArcMap. Click No to discard any changes.

4. If you plan to work on another exercise, follow the substeps below.
a. Click File > New.

The New Document dialog box opens.
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b. Click OK.

c. Click No when prompted to save changes.

Network Analyst Tutorial

Copyright © 1995-2010 Esri. All rights reserved. 41



Exercise 5: Calculating service areas and creating an
OD cost matrix
In this exercise, you will create a series of polygons that represent the
distance that can be reached from a facility within a specified amount of
time. These polygons are known as service area polygons. You will calculate
3-, 5-, and 10-minute service areas for six warehouses in Paris.

You will also find how many stores are within each of these service areas.
You will identify one warehouse that should be relocated to better service
the stores. Additionally, you will create an origin–destination cost matrix for
delivery of goods from the warehouses to all stores within a 10-minute drive
time. Such a matrix is used as an input for logistics, delivery, and routing analyses.

Preparing your display

Steps:

1. If you have Exercise05.mxd open in ArcMap, skip to step 6.

2. Start ArcMap by clicking Start > All Programs > ArcGIS > ArcMap 10.

3. On the ArcMap - Getting Started dialog box, click Existing Maps > Browse for more.

4. Browse to C:\ArcGIS\ArcTutor\Network Analyst\Tutorial.
This is the default installation location for the tutorial data.

5. Double-click Exercise05.mxd.
The map document opens in ArcMap.

6. Enable the Network Analyst extension.
a. Click Customize > Extensions.

The Extensions dialog box opens.

b. Check Network Analyst.

c. Click Close.

If the Network Analyst toolbar is not displayed, you need to add it.

7. Click Customize > Toolbars > Network Analyst.
The Network Analyst toolbar is added to ArcMap.

If the Network Analyst window is not displayed, you need to add it.

8. On the Network Analyst toolbar, click the Show/Hide Network Analyst Window button .
The dockable Network Analyst window opens.

Complexity:
Beginner

Data Requirement:
ArcGIS Tutorial Data Setup

Data Path:
C:\ArcGIS\ArcTutor\Network
Analyst\Tutorial

Goal:
Create service area polygons and create
an OD cost matrix.
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You can dock or undock the Network Analyst window. In this exercise, it is docked below the
Table Of Contents window.

Creating the service area analysis layer

Steps:

1. Click Network Analyst on the Network Analyst toolbar and click New Service Area.

The service area analysis layer is added to the Network Analyst window. The network
analysis classes (Facilities, Polygons, Lines, Point Barriers, Line Barriers, and Polygon
Barriers) are empty.

The analysis layer is also added to the Table Of Contents window.
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Adding facilities

Next, you will add warehouses as facilities for which the service area polygons will be generated.

Steps:

1. On the Network Analyst window, right-click Facilities (0) and choose Load Locations.

The Load Locations dialog box opens.

2. In the Load From drop-down list, choose Warehouses.

3. Click OK.
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The six facilities are displayed in the map.

4. In the Network Analyst window, click the plus (+) sign next to Facilities (6) to see a list of the
loaded facilities.

Setting up the parameters for the analysis

Next, you will specify that your service area will be calculated based on drive time (using minutes). Three
service area polygons will be calculated for each facility, one at 3 minutes, one at 5 minutes, and another
at 10 minutes. You will specify that the direction of travel will be from the facility—not toward the facility,
that no U-turns are allowed, and that one-way restrictions must be followed.

Steps:

1. Click the Analysis Layer Properties button on the Network Analyst window.

The Layer Properties dialog box opens.

2. Click the Analysis Settings tab.

3. Make sure that Impedance is set to use DriveTime (Minutes).

4. Type 3 5 10 in the Default Breaks text box.

5. Under Direction, click Away From Facility.

6. Choose Not Allowed from the U-Turns at Junctions drop-down list.

7. Leave Ignore Invalid Locations checked.

8. Check Oneway in the Restrictions list.

The Analysis Settings tab should now look like this:
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9. Click the Polygon Generation tab.

10. Make sure that Generate Polygons is checked.

11. For Polygon Type, click Generalized.
Detailed polygons are more accurate but need more time to be generated.

12. Uncheck the Trim Polygon option.
This is a postprocess that trims the outside polygon to remove spikes but takes a little longer
to run.

13. Click Overlapping for the Multiple Facilities Options.
This results in individual polygons for each facility. A polygon from one facility might overlap
with a polygon from another, nearby facility.

14. Click Rings for the Overlap type.
This excludes areas of smaller breaks from the polygons of a bigger break.

15. Click Apply to save the settings.

16. Click the Line Generation tab.

17. Leave Generate Lines unchecked.

18. Click OK.

Run the process to compute the service area

Steps:

1. Click the Solve button on the Network Analyst toolbar.
The service area polygons appear on the map and on the Network Analyst window.

The polygons are transparent, which allow you to see the underlying streets. However, instead
of color coding the breaks from dark to light with increasing distance, you will change them to
go from light to dark.

2. In the Table Of Contents window, right-click the Polygons sublayer and choose Properties.
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3. Click the Symbology tab.

4. Click the Symbol field name and choose Flip Symbols. (Make sure you click—not right-
click—Symbol; otherwise, you get a different context menu.)

5. Click OK.
The outer and inner service area breaks switch colors, making it clearer what areas the
10-minute breaks cover.

Identifying stores that are outside all service areas

Steps:

1. In the Table Of Contents window, click and drag Stores to the top of the Layers list to
improve visibility.
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2. Click Selection > Select By Location.

3. Create the selection query on the Select By Location dialog box to select features from
stores that are completely within polygons, as shown below.

4. Click OK.
The stores that are within the polygons are selected; however, you want to select the stores
that are outside the service area polygons.

5. In the Table Of Contents window, right-click Stores and click Selection > Switch Selection.
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The selection now shows the distribution of stores not contained in any service area polygons.
Use this selection to identify the area in which you will relocate a warehouse. The best area
appears to be in the center of the map.

6. On the Tools toolbar, click the Clear Selected Features button .

Relocating the least accessible warehouse

Look at the service area polygons of Warehouse #2. There are not any stores within the 3-, 5-, or
10-minute service areas around Warehouse #2; hence, you will relocate that warehouse to better service
the stores.

Steps:

1. On the Network Analyst window, select Warehouse #2 under Facilities (6).

2. Click the Select/Move Network Location Tool on the Network Analyst toolbar.
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3. On the map display, drag Warehouse #2 to the center of the map as shown below.

Run the process to compute the service area

Steps:

1. Click the Solve button on the Network Analyst toolbar.
The service area polygons appear on the map and the Network Analyst window.

Identifying the service area polygon that each store is within

Steps:

1. In the Table Of Contents window, right-click Stores and click Joins and Relates > Join.

The Join Data dialog box opens.

2. Choose Join data from another layer based on spatial location.

3. Choose Polygons as the layer to join to this layer.
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4. Click the it falls inside button.

This adds the attributes of the polygon to all points that fall inside the polygon.

5. Specify an output shapefile or feature class to save the join results to and name it
StoresWithPoly.

6. Click OK.
ArcGIS performs the join and adds the new layer to the map document.

7. In the Table Of Contents window, right-click the new StoresWithPoly feature layer and
choose Open Attribute Table.
Each row in the table displays the name of the store and polygon it falls under. You can use
this table to generate other useful categories, such as the number of stores within 0-to
3-minute service areas.

8. Close the attribute table.

You can optionally export your facilities (including the one you moved) as a feature class.

9. In the Network Analyst window, right-click Facilities (6) and choose Export Data.
The Export Data dialog box opens.

10. In the Export drop-down list, choose All features.

11. Choose an output location and type (shapefile or feature class).
You might choose to store a feature class in the Paris geodatabase:
C:\arcgis\ArcTutor\Network Analyst\Tutorial\Paris.gdb\New_Warehouses
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12. Click OK.
A message appears asking if you want to add the exported data to the map.

13. Click No.
You won't need the data for the rest of this exercise.

Creating an OD cost matrix analysis layer

Optionally, you can create an origin–destination cost matrix for deliveries from the new warehouses to
each store. The results of this matrix can be used to identify stores that will be serviced by each
warehouse within a 10-minute drive time. Also, you can find the total drive time from each warehouse to
its stores.

Steps:

1. In the Table Of Contents window, uncheck the Service Area analysis layer and the
StoresWithPoly feature layer to improve readability of the map.

2. Click Network Analyst on the Network Analyst toolbar and click New OD Cost Matrix.

The OD cost matrix analysis layer is added to the Network Analyst window. The network
analysis classes (Origins, Destinations, Lines, Point Barriers, Line Barriers, and Polygon
Barriers) are empty.
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The analysis layer is also added to the Table Of Contents window.

Adding origins

You can use the facilities from the service area analysis (in the previous sections) as origins. If you have
not completed the section on service areas, you can use the Warehouses feature layer instead.

Steps:

1. In the Network Analyst window, right-click Origins (0) and choose Load Locations.
The Load Locations dialog box opens.

2. Click ServiceArea/Facilities in the Load From drop-down list. (If you did not complete the
previous sections on service area analysis, you can choose Warehouses instead.)

3. Uncheck Only load selected rows.

4. Under Location Position, click Use Network Location Fields. (If you are loading
Warehouses, click Use Geometry.)
Using network location fields allows ArcGIS to use the already-located position of service area
facilities to locate them again as origins. This is much faster than using a spatial search to
locate them again.
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5. Click OK.
The six new origins are displayed on the map and listed in the Network Analyst window under
Origins.

Adding destinations

Steps:

1. In the Network Analyst window, right-click Destinations (0) and choose Load Locations.

2. Choose Stores in the Load From drop-down list.

3. Under Location Analysis Properties, for the property name, choose NOM from the Field
drop-down list.
Since the French field name NOM is not configured in the NASolverConfiguration.xml file,
ArcGIS is unable to map the field name automatically.
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4. Click OK.
The Network Analyst window now lists 21 destinations.

These destinations are also displayed on the map.

Network Analyst Tutorial

Copyright © 1995-2010 Esri. All rights reserved. 55



Setting up the parameters for the analysis

Next, you will specify that your OD cost matrix will be calculated based on drive time. You will set a default
cutoff value of 10 minutes and ensure that all destinations are found within the specified cutoff.
Additionally, you will specify that U-turns are allowed everywhere and the output Shape type should be a
straight line. Since all these trips are on roads, one-way restrictions must be followed. All invalid locations
(locations not found) will be ignored.

Steps:

1. Click the Analysis Layer Properties button on the Network Analyst window.

2. Click the Analysis Settings tab.

3. Make sure that the Impedance drop-down list is set to DriveTime (Minutes).

4. Type 10 in the Default Cutoff Value text box.
This will create origin–destination paths from each warehouse to all stores that can be reached
within 10 minutes.

5. Make sure that Destinations To Find is set to <All>.

6. Click the U-Turns at Junctions drop-down arrow and choose Allowed.

7. Make sure that Output Shape Type is set to Straight Line.

8. Make sure that Ignore Invalid Locations is checked.

9. Check Oneway in the Restrictions list.

10. Click OK.
The parameter settings are saved.
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Run the process to create the OD cost matrix

Steps:

1. Click the Solve button on the Network Analyst toolbar.
The OD lines appear on the map. There are 24 lines in this example. This number may be
different for you, depending on where you relocated Warehouse #2.

2. If the Service Area layer is not displayed, turn it on to show the OD Cost Matrix layer on top of
the service areas of the warehouses.

Allocating stores to warehouses

Based on the OD cost matrix, you can now identify the stores that would be served by each warehouse.

Steps:

1. In the Network Analyst window, right-click Lines (24) and choose Open Attribute Table.

The Lines table opens.

The Lines table represents the origin–destination cost matrix from each warehouse to the stores
within a 10-minute drive time. The OriginID column contains IDs of warehouses. The
DestinationID column contains IDs of stores. The DestinationRank is a rank assigned to each
destination that is served by a store based on the total drive time. For example, in the table
below, for Warehouse #1, DestinationID 2 has a rank of 1, and DestinationID 3 has a rank of 2.
This is because it takes less time to go from Warehouse #1 to DestinationID 2. (This may be
different for you, as your analysis results are dependent on the source feature class of the
origins and destinations.)
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The OD cost matrix displays the stores serviced by each warehouse along with the total drive
time for each route. Some stores are within a 10-minute accessibility zone of more than one
warehouse and can be served by any one of them. The OD cost matrix can also be used as an
input in logistics routing models that use origin–destination matrices to allocate goods and
services.

2. If you don't plan to work on any other exercise, exit ArcMap. Click No to discard any changes.

3. If you plan to work on another exercise, follow the substeps below.
a. Click File > New.

The New Document dialog box opens.

b. Click OK.

c. Click No when prompted to save changes.
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Exercise 6: Creating a model for route analysis
In this exercise, you will create a model for finding the fastest delivery route
connecting 21 stores in Paris.

Preparing your display

Steps:

1. If you have Exercise06.mxd open in ArcMap, skip to step 6.

2. Start ArcMap by clicking Start > All Programs > ArcGIS >
ArcMap 10.

3. On the ArcMap - Getting Started dialog box, click Existing Maps > Browse for more.

4. Browse to C:\ArcGIS\ArcTutor\Network Analyst\Tutorial.
This is the default installation location for the tutorial data.

5. Double-click Exercise06.mxd.
The map document opens in ArcMap.

6. Enable the Network Analyst extension.
a. Click Customize > Extensions.

The Extensions dialog box opens.

b. Check Network Analyst.

c. Click Close.

If the Network Analyst toolbar is not displayed, you need to add it.

7. Click Customize > Toolbars > Network Analyst.
The Network Analyst toolbar is added to ArcMap.

If the Network Analyst window is not displayed, you need to add it.

8. On the Network Analyst toolbar, click the Show/Hide Network Analyst Window button .
The dockable Network Analyst window opens.

You can dock or undock the Network Analyst window. In this exercise, it is docked below the
Table Of Contents window.

Complexity:
Beginner

Data Requirement:
ArcGIS Tutorial Data Setup

Data Path:
C:\ArcGIS\ArcTutor\Network
Analyst\Tutorial

Goal:
Create a geoprocessing model using
ModelBuilder and ArcGIS Network
Analyst tools.
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Creating the model

Steps:

1. Click the Catalog window button on the Standard toolbar.
The dockable Catalog window opens.

2. In the Catalog window, expand Toolboxes.

3. Right-click My Toolboxes and choose New > Toolbox.

4. Type NetworkModel and press ENTER to name the newly added toolbox.

5. Right-click the NetworkModel toolbox and click New > Model.

A new model appears in the toolbox, and the Model dialog box opens.
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Creating a route layer in the model

Next, you will create the route layer within the model. The workflow for using Network Analyst in a model
is the same as the workflow for using Network Analyst in ArcMap. First, you create a route layer and set
properties. Next, you add the network locations (stops) to be used as inputs. Last, you solve and display
the results.

Steps:

1. On the menu bar, click Geoprocessing > Search For Tools.
The dockable Search window opens with the Tools category selected.

2. Click Network Analyst Tools in the list of toolboxes in the Search window.
A list of toolsets and tools related to the ArcGIS Network Analyst extension are listed.

3. Click Analysis in the Search window.
Only tools related to network analysis are displayed in the Search window.
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4. Drag the Make Route Layer link onto the Model dialog box.

5. On the Model dialog box, double-click Make Route Layer.
The Make Route Layer dialog box opens so you can set its properties.

6. Click the Input analysis network drop-down arrow and choose ParisMultimodal_ND.

7. In the Impedance attribute drop-down list, click DriveTime.

8. Check the Reorder stops to find optimal route check box.

9. In the Preserve ordering of stops drop-down list, click PRESERVE_BOTH.

The tool dialog box should look like the one in the graphic below.
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10. Click OK.
The input analysis layer is now added to the model. The Make Route Layer tool turns yellow,
and the output turns green.

11. Click the Full View button .
The entire model is displayed.

Adding stops to the route layer

Next, you will add the stores as stops by using the Add Locations tool.

Steps:

1. Drag the Add Locations tool from the Search window onto the Model dialog box.

2. Select the Stores feature layer in the Table Of Contents window and drag it onto the model to
the left of Add Locations.
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3. On the Model dialog box, click the Connect tool .

4. Click Stores and click Add Locations to connect them. Click Input locations on the context
menu that appears.

5. Using the Connect tool , connect Route to Add Locations. Click Input network analysis
layer on the context menu that appears.

6. Click the Auto Layout button .
The model is arranged in a logical order.
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7. Click the Full View button .

Adding the Solve tool

Steps:

1. Drag the Solve tool from the Search window onto the Model dialog box.

2. Using the Connect tool , connect the output layer, Network Analyst Layer, to Solve. Click
Input network analysis layer on the context menu that appears.
The Solve tool turns yellow, the output layer turns green, and Solve succeeded turns cyan.

3. Click the Auto Layout button .
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4. Click the Full View button .

5. Click the Select tool .

6. Right-click the output layer of the Solve tool, which is labeled Network Analyst Layer (2), and
click Add To Display.

This tells the model to add the final output to the map display.

Running the model to find the best route

Steps:

1. Click the Save button to save the model.

2. Click the Run button .
A status window appears while ArcGIS performs the route analysis.

3. When completed, close the status window and close the Model dialog box so you can inspect
the results.
A message appears prompting you to save the model.

4. Click Yes.

A new route layer is added to the Table Of Contents window. The Network Analyst window
has all the stops and the resultant route. The map displays the stops that were loaded and the
resultant route.
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Configuring the model to save the results to disk

Steps:

1. In the Catalog window, expand the NetworkModel toolbox, right-click Model, then choose
Edit.

To access the shortest path feature class for further analysis, you will need to copy features
from memory onto disk.

2. Type Select Data in the Search window text box and press ENTER.

3. Drag the Select Data tool from the search results and drop it in the Model window.

4. Using the Connect tool , connect the final output layer to Select Data. Click Input Data
Element on the context menu that appears.

5. In the Model window, double-click Select Data.
The Select Data dialog box opens.

6. Choose Routes from the Child Data Element drop-down list.

7. Click OK.
The dialog box closes.

8. Type Copy Features in the Search window text box and press ENTER.

9. Drag the Copy Features tool from the search results onto the Model dialog box.

10. Using the Connect tool , connect the final output layer to Copy Features. Click Input
Features on the context menu that appears.

Network Analyst Tutorial

Copyright © 1995-2010 Esri. All rights reserved. 67



11. On the Model dialog box, double-click Copy Features.
The Copy Features dialog box opens.

12. Enter an output location for saving the route as a feature class or shapefile.
For example, you might type C:\arcgis\ArcTutor\Network
Analyst\Tutorial\Paris.gdb\path.

13. Click OK.

Now running the model will solve the best route, select the route sublayer, and export it to a
feature class. You can run the model by clicking the Run button .

Deleting the model

Steps:

1. In the Catalog window, navigate to the NetworkModel toolbox, right-click Model, then choose
Delete.

A message appears prompting you to confirm deletion.

If you ran the model, you may also want to navigate to the location that you specified for the
output of the Copy Features tool and delete the feature class that was created.

2. Click Yes.

3. Exit ArcMap and do not save any changes to Exercise06.mxd.
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Exercise 7: Servicing a set of orders with a fleet of
vehicles
In this exercise, you will find the best routes for a fleet of vehicles, operated
by a distribution company, to deliver goods from a distribution center to a set
of 25 grocery stores. Each store has a specific quantity of demand for the
goods, and each truck has a limited capacity for carrying the goods. The
main objective is to assign trucks in the fleet a subset of the stores to service
and to sequence the deliveries in a way that minimizes the overall
transportation costs.

This can be achieved by solving a vehicle routing problem (VRP). Once the delivery sequence is determined,
you will generate the turn-by-turn directions for the resulting routes, which can be electronically distributed or
printed and given to the drivers to make the deliveries.

Preparing your display

Steps:

1. If you have Exercise07.mxd open in ArcMap, skip to step 6.

2. Start ArcMap by clicking Start > All Programs > ArcGIS > ArcMap 10.

3. On the ArcMap - Getting Started dialog box, click Existing Maps > Browse for more.
The Open ArcMap Document dialog box appears.

4. Browse to C:\ArcGIS\ArcTutor\Network Analyst\Tutorial.
This is the default installation location for the tutorial data.

5. Double-click Exercise07.mxd.
The map document opens in ArcMap.

6. Enable the Network Analyst extension.
a. Click Customize > Extensions.

The Extensions dialog box opens.

b. Check Network Analyst.

c. Click Close.

If the Network Analyst toolbar is not displayed, you need to add it.

7. Click Customize > Toolbars > Network Analyst.
The Network Analyst toolbar is added to ArcMap.

If the Network Analyst window is not displayed, you need to add it.

8. On the Network Analyst toolbar, click the Show/Hide Network Analyst Window button .
The dockable Network Analyst window opens.

Complexity:
Beginner

Data Requirement:
ArcGIS Tutorial Data Setup

Data Path:
C:\ArcGIS\ArcTutor\Network
Analyst\Tutorial

Goal:
Solve a vehicle routing problem analysis.
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You can dock or undock the Network Analyst window. In this exercise, it is docked below the
Table Of Contents window.

Creating the vehicle routing problem analysis layer

Steps:

1. Click Network Analyst on the Network Analyst toolbar and click New Vehicle Routing
Problem.

The vehicle routing problem analysis layer is added to the Network Analyst window. The
network analysis classes (Orders, Depots, Routes, Depot Visits, Breaks, Route Zones, Route
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Seed Points, Route Renewals, Specialties, Order Pairs, Point Barriers, Line Barriers, and
Polygon Barriers) are empty.

The analysis layer is also added to the Table Of Contents window.

Adding orders

You will add the grocery store locations to the Orders network analysis class. You can think of orders as
orders to be filled, since each grocery store has requested goods to be delivered to it from the distribution
center. Members of the Orders class will eventually become stops along the vehicle's routes.
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The grocery store locations are already added as a feature layer, Stores, in the map document. The
attributes of Stores contain information about the total weight of goods (in pounds) required at each store,
the time window during which the delivery has to be made, and the service time (in minutes) incurred
while visiting a particular store. The service time is the time required to unload the goods.

You will add these point features of stores as orders in the analysis layer.

Steps:

1. In the Network Analyst window, right-click Orders (0) and choose Load Locations.

The Load Locations dialog box opens

2. Select Stores from the Load Locations drop-down list.

The Location Analysis Properties section on the Load Locations dialog box lets you specify
which attributes of the Stores feature class contain the values that ArcGIS Network Analyst will
use to help solve this vehicle routing problem.

3. In the Location Analysis Properties section, make sure that the Name property is
automatically matched to the NAME field, and the ServiceTime property is matched to the
ServiceTime field.
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Network Analyst tries to match location analysis properties automatically for a newly created
vehicle routing problem layer based on a configuration file (located in the ArcGIS installation
directory within [...]\NetworkAnalyst\NetworkConfiguration\NASolverConfiguration.xml).

4. Set the Field value of TimeWindowStart1 to TimeStart1.

5. Set the Field value of TimeWindowEnd1 to TimeEnd1.

6. Set the Field value of DeliveryQuantities to Demand.

7. Type 0 under Default Value for the MaxViolationTime1 property.
Setting this property to zero specifies that the time window should not be violated.
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8. Click OK.
Twenty-five stores are listed in the Network Analyst window under Orders and are displayed
as orders on the map.

Adding depots

The goods are delivered from a single distribution center whose location is shown in the
DistributionCenter feature layer in ArcMap. The distribution center operates between 8:00 a.m. and 5:00
p.m. You will add this point feature to the Depots network analysis class.

Steps:

1. In the Network Analyst window, right-click Depots (0) and choose Load Locations.
The Load Locations dialog box opens.

2. Select DistributionCenter from the Load Locations drop-down list.

3. In the Location Analysis Properties section, make sure that the Name property is
automatically matched to the NAME field.

4. Type 8 AM under Default Value for the TimeWindowStart1 property.

5. Type 5 PM under Default Value for the TimeWindowEnd1 property.
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6. Click OK.
One distribution center is listed in the Network Analyst window under Depots and displayed
as a depot on the map.

Adding Routes

The distribution center has three trucks, each with a maximum capacity to carry 15,000 pounds of goods.
You will add three routes (one for each vehicle) and set the properties for the routes based on the center's
operational procedures.

Steps:

1. In the Network Analyst window, right-click Routes (0) and choose Add Item.

A new route, Item 1, is added under the Routes class in the Network Analyst window, and
the Properties window for the route opens.

2. In the Properties window, specify the attributes for the route as shown in the table below. The
description column of the table explains the use of particular values. Leave default values for
attributes not in the table.

Attribute Value Description
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Name Truck_1 Name of the vehicle.

StartDepotName San
Francisco

The truck starts at the distribution center.

EndDepotName San
Francisco

The truck returns to the distribution center at the end
of the route.

StartDepotServiceTime 60 Time (in this case, minutes) required to fully load the
truck with goods.

EarliestStartTime 8 AM The truck can start operation as soon as the
distribution center opens at 8:00 a.m.

LatestStartTime 8 AM The truck must start operation as soon as possible.

Capacities 15000 The truck can carry a maximum of 15,000 pounds of
goods.

CostPerUnitTime 0.20 The truck driver is paid 12 dollars per hour, so the
wage is: $12.00/60 minutes = $0.20 per minute.

CostPerUnitDistance 1.5 The average dollar amount spent per mile on fuel
consumption, truck depreciation, and maintenance.

MaxOrderCount 10 The maximum number of stores that can be serviced
by a truck.

MaxTotalTime 360 Due to workday constraints, drivers can't have a work
shift of more than six hours (360 minutes).

MaxTotalTravelTime 120 To satisfy the workday constraints and still be able to
serve a reasonable number of stores—while taking
into account the service time needed at a store—the
truck should not spend more than two hours (120
minutes) driving on the streets.

MaxTotalDistance 80 To balance daily fuel and maintenance costs among
the fleet, any one truck should not travel more than 80
miles on its route.
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3. Click OK.
A new route, Truck_1, is added to the routes class in the Network Analyst window.

Since the three trucks at the distribution center are the same, you can make two copies of the
first truck you entered and rename them.

4. Right-click the Truck_1 route object in the Network Analyst window and choose Copy.

5. Right-click the Route (1) class in the Network Analyst window and choose Paste.
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The Routes class contains two identical route objects.

6. Repeat the last step to create a third route object.

7. Double-click the second Truck_1 object in the list.
The Properties window opens.

8. Click the Name property and type Truck_2.

9. Press ENTER twice.
The route is given a unique name, and the window closes.

10. Use the same procedure to change the name of the last route to Truck_3.
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Setting up the properties for the vehicle routing problem analysis

Steps:

1. Click the Analysis Layer Properties button on the Network Analyst window.

The Layer Properties dialog box opens.

2. Click the Analysis Settings tab.

3. Make sure that the Time Attribute drop-down list is set to TravelTime (Minutes).
The VRP solver will use this attribute to calculate time-based costs between orders and the
depot.

4. Click the Distance Attribute drop-down list and choose Meters.
This attribute is used to determine travel distances between orders and the depot for constraint
purposes and creating directions; however, the VRP solver's objective is to minimize time
costs.

5. Set the Default Date to Day of Week. Choose Monday in the Day of Week drop-down list.

6. Make sure that Capacity Count is set to 1.
This setting indicates that the goods being delivered have only one measurement. In this case,
that measurement is weight (pounds). If the capacities were specified in terms of two
measurements, such as weight and volume, then the capacity count would be set to 2.

7. Make sure that Minutes is selected for Time Field Units.
This specifies that all time-based attributes, such as ServiceTime and MaxViolationTime1 for
Orders and MaxTotalTime, MaxTotalTravelTime, and CostPerUnitTime for Route, are in
minutes.

8. Make sure that Distance Field Units is set to Miles.
This specifies that all distance-based attributes, such as MaxTotalDistance and
CostPerUnitDistance for Routes, are in miles.

9. Since it is difficult for these delivery trucks to make U-turns, set U-Turns at Junctions to Not
Allowed.

10. Select Straight Line in the Output Shape Type drop-down list.
You could select either the True Shape with Measures or True Shape option if you wanted
the routes to follow the streets. Note that this option only affects the display of the routes, not
the results determined by the VRP solver.

11. Make sure that Use Hierarchy is checked.

12. In the Restrictions frame, make sure that RestrictedTurns and Oneway are checked.

13. Leave the options that are in the Directions frame set to their default values.
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14. Click OK.

Run the process to determine the best route assignment and order sequence

Steps:

1. Click the Solve button on the Network Analyst toolbar.
The VRP solver calculates the three routes required to service the orders and draws lines
connecting the orders. Each route begins and ends at the distribution center and serves a set
of orders along the way.

If you receive any error messages, make sure that the value of the Capacities attribute for the
routes is set to 15000 instead of 15,000 and each route has a unique name.

Determine turn-by-turn directions for the routes

Steps:
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1. Right-click Routes (3) in the Network Analyst window and click Selection > Clear Selected
Features.

2. Click the Directions Window button on the Network Analyst toolbar.
The Directions dialog box opens.

3. Optionally, you can export the Vehicle Routing Problem layer as a layer file (<filename>.lyr) by
right-clicking Vehicle Routing Problem in the Table Of Contents window and choosing Save
As Layer File. This saves the analysis on disk so that you can add it to a different map
document and reuse it later.

4. If you want to continue on to the following advanced sections of this tutorial exercise, close the
Directions window. Otherwise, exit ArcMap and do not save any changes to Exercise 07.mxd.

Make changes to the existing solution to solve a different scenario

The vehicle routing problem solution obtained earlier worked well for the company. After a few weeks,
however, the driver assigned to Truck_2 went on vacation. So now the distribution company has to service
the same stores but with just two trucks. To accommodate the extra workload, the company decided to pay
overtime to the other two drivers and provide them with one paid break during the day. The distribution
company also acquired two additional satellite distribution centers. These centers can be used by the trucks
to renew their truckload while making their deliveries instead of returning to the main distribution center for
renewal. You will modify the solution obtained from the previous step to accommodate these changes.

Deleting an existing route from a solution

Steps:

1. In the Network Analyst window, right-click the Truck_2 object in the Routes class and click
Delete.

Adding route renewals

The two satellite distribution centers that the company acquired are at 800 Brush Street and 100 Old
County Road, and they can act as renewal locations for the trucks. The trucks can refill their cargo by
visiting these renewal locations and thus save time by not returning to the starting depots. You will add the
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renewal locations to the Depots network analysis class by geocoding their addresses. The routes that can
renew at a renewal location and the service time for the renewal are specified in the Route Renewals
network analysis class.

Steps:

1. In the Network Analyst window, right-click Depots (1) and choose Find Address.
The Find dialog box opens.

2. Choose SanFranciscoLocator from the Choose an address locator drop-down list.

3. In the Street or Intersection box, type 800 Brush St.

4. Click Find.
The SanFranciscoLocator, which is an address locator that was already added to the
Exercise07.mxd, finds the address and shows the result at the bottom of the Find dialog box.

5. Right-click the result on the Find dialog box and choose Add as Network Analysis Object.
The located address is added as a depot in the Network Analyst window and the map
display.

6. In the Street or Intersection box of the Find dialog box, type 100 Old County Rd.

7. Click Find.

8. Right-click the new result at the bottom of the Find dialog box and choose Add as Network
Analysis Object.
A third depot is added to the Depots network analysis class.

9. Close the Find dialog box.

Since both trucks are allowed to renew their loads at the 800 Brush Street and 100 Old County
Road locations, you will associate each truck with the two renewal locations. The VRP solver
will figure out the best renewal location for the trucks.

10. In the Network Analyst window, right-click Route Renewals (0) and click Add Item.
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A new route renewal object, Item1, is added under the Route Renewals class in the Network
Analyst window, and the Properties window for Item1 opens.

11. In the Properties window, specify the attributes for the route renewal as shown below.

Attribute Value Description

DepotName 800 Brush St The truck can use this depot location for renewal.

RouteName Truck_1 Name of the vehicle.

ServiceTime 30 Time in minutes required to load the truck.

12. Click OK.
A new route renewal object, 800 Brush St, is listed within the Truck_1 item in the Network
Analyst window.

13. Follow the last three steps to add three more route renewal objects such that each truck
(Truck_1 and Truck_3) can reload at both the renewal locations (800 Brush St, 100 Old
County Rd).
The Network Analyst window should now have two route renewal objects listed within the
Truck_1 and Truck_3 items, respectively.
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Modifying routes to include overtime

To accommodate the extra workload, the company wants to remove the maximum time, maximum travel
time, and maximum distance constraints for the routes. Since the drivers have to work longer than before,
they are provided with overtime pay at the rate of $18 per hour after completing six hours of work. In this
step, you will make these changes to the routes.

Steps:

1. In the Network Analyst window, under the Routes network analysis class, double-click
Truck_1.
The Properties window opens.

2. Make changes to the attributes of Truck_1 so they match the values in the table below.

Attribute Value Description

OvertimeStartTime 360 The driver is paid overtime if he or she works for more than
six hours (360 minutes).

CostPerUnitOvertime 0.3 The truck driver is paid $18 per hour for the overtime. So the
wage in dollars per minute is: $18.00/60 minutes = $0.30 per
minute.

MaxOrderCount 20 Since the driver is paid overtime, he or she is expected to
service more stores.

MaxTotalTime <Null> There are no restrictions on the total duration of the work shift
for the driver.

MaxTotalTravelTime <Null> There are no restrictions on the time spent driving on the
streets.

MaxTotalDistance <Null> There are no restrictions on the total distance traveled by a
truck.
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3. Click OK.

4. Repeat the last three steps for Truck_3.

Adding breaks

Since the drivers have to work longer, they will require one half hour break during their work shift. In this
step, you will specify the breaks for each route.

Steps:

1. In the Network Analyst window, right-click Breaks (0) and choose Add Item.
The Properties window opens.

2. Specify the attribute values for the new break as shown in the table below.

Attribute Value Description

TimeWindowStart 12:30
PM

The break has to start sometime after 12:30 p.m.

TimeWindowEnd 1:30 PM The break has to start sometime before 1:30 p.m.

RouteName Truck_1 The name of the route to which this break applies.

ServiceTime 30 The break duration in minutes.

MaxViolationTime 0 The break has to start between 12:30 p.m. and 1:30 p.m. The
zero value indicates that the break can't start after 1:30 p.m.
(that is, the break time-window is rigid).

IsPaid True It is a paid break, so the cost is included in the total cost of the
route.
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3. Click OK.

4. Repeat the last three steps, entering Truck_3 for the RouteName property.
The Network Analyst window now has two objects listed under the Breaks class: Truck_1
and Truck_3.

Determining the solution

Steps:

1. Click the Solve button on the Network Analyst toolbar.
The VRP solver calculates the two routes that can be used to service the orders and draws
straight lines connecting the orders. Each route begins and ends at the distribution center,
serves a set of orders along the way, visits a renewal location to load the truck again,
continues to service the remaining orders, and finally returns to the distribution center.
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This solution meets all the constraints specified by the distribution company. However, after
giving the route itinerary to the two drivers, the company discovered that the driver of Truck_1
prefers driving in the downtown area and the driver of Truck_3 prefers driving in the East Bay
area. The company would like to determine a new solution in which the routes service the
orders that are in the areas their drivers prefer. In the next steps, you will add route seed
points to incorporate these driver preferences.

Adding route seed points

In this step, you will add route seed points for Truck_1 and Truck_3 by geocoding addresses. Note that
the route seed points can also be imported from an existing point feature class or can be created
interactively by using the Create Network Location tool .

Steps:

1. In the Network Analyst window, right-click Route Seed Points (0) and choose Find
Address.
The Find dialog box opens.

2. In the Street or Intersection combo box, type 278 Dorantes Ave.

3. Click Find.
The SanFranciscoLocator finds the address and shows the result at the bottom of the dialog
box.

4. Right-click the result and choose Add as Network Analysis Object.
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The location of the address is added as a route seed point. It is shown in the Network Analyst
window and the map display.

5. Close the Find dialog box.

6. In the Network Analyst window, double click the new route seed point, 278 Dorantes Ave.
The Properties dialog box opens.

7. Specify the attribute values for the route seed point as shown in the table below.

Attribute Value Description

RouteName Truck_1 The name of the route to which this seed point applies.

SeedPointType Static This makes it more likely that the orders near the specified seed
point will be assigned to Truck_1.

8. Repeat steps 1–5 in this section to add another route seed point at 1888 Peralta St.

9. Repeat steps 6 and 7 to change the RouteName attribute of the second seed point to
Truck_3.

Determine the solution

Steps:

1. Click the Solve button on the Network Analyst toolbar.
The VRP solver calculates the two routes that can be used to service the orders and draws
straight lines connecting the orders. The route for Truck_1 includes orders in the downtown
region only.

2. Exit ArcMap without saving any changes.
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Exercise 8: Finding best routes to service paired orders
In this exercise, your goal is to find the best routes for a fleet of vans to
transport people who would otherwise not have access to transportation
from their homes to different hospitals for medical appointments. You will
accomplish this by solving a vehicle routing problem (VRP) analysis using
order pairs, which relate and sequence two orders (stops) so that the vans
will pick up riders and take them to their proper destinations. Using other
features of the VRP analysis layer, you'll also make sure that additional
requirements are met. For instance, you will enter a max transit time for
order pairs so that riders don't spend too much time in transit. You'll use time windows on orders so that riders
are not late for their appointments. Some riders require wheelchairs; you'll use specialties to match those
riders with vans that have wheelchair lifts. Once the routes are determined, you will generate turn-by-turn
directions of the resulting routes, which can be electronically distributed or printed and given to the drivers.

Preparing your display

Steps:

1. If you have Exercise08.mxd open in ArcMap, skip to step 6.

2. Start ArcMap by clicking Start > All Programs > ArcGIS > ArcMap 10.

3. On the ArcMap - Getting Started dialog box, click Existing Maps > Browse for more.
The Open ArcMap Document dialog box appears.

4. Browse to C:\ArcGIS\ArcTutor\Network Analyst\Tutorial.
This is the default installation location for the tutorial data.

5. Double-click Exercise08.mxd.
The map document opens in ArcMap.

6. Enable the Network Analyst extension.
a. Click Customize > Extensions.

The Extensions dialog box opens.

b. Check Network Analyst.

c. Click Close.

If the Network Analyst toolbar is not displayed, you need to add it.

7. Click Customize > Toolbars > Network Analyst.
The Network Analyst toolbar is added to ArcMap.

If the Network Analyst window is not displayed, you need to add it.

8. On the Network Analyst toolbar, click the Show/Hide Network Analyst Window button .
The dockable Network Analyst window opens.

Complexity:
Beginner

Data Requirement:
ArcGIS Tutorial Data Setup

Data Path:
C:\ArcGIS\ArcTutor\Network
Analyst\Tutorial

Goal:
Solve a vehicle routing problem analysis
with order pairs.
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You can dock or undock the Network Analyst window. In this exercise, it is docked below the
Table Of Contents window.

Creating the vehicle routing problem analysis layer

Steps:

1. Click Network Analyst on the Network Analyst toolbar and click New Vehicle Routing
Problem.

The vehicle routing problem analysis layer is added to the Network Analyst window. The
network analysis classes (Orders, Depots, Routes, Depot Visits, Breaks, Route Zones, Route
Seed Points, Route Renewals, Specialties, Order Pairs, Point Barriers, Line Barriers, and
Polygon Barriers) are empty.

The analysis layer is also added to the Table Of Contents window.
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Adding specialties

The logistics company has three vans. One of the vans that operates in the downtown area is equipped to
provide access for wheelchairs. You will add Wheelchair as a specialty so that the orders that require this
specialty can be assigned to the route that has a wheelchair lift.

Steps:

1. In the Network Analyst window, right-click Specialties (0) and click Add Item.

A new specialty, Item 1, is added under the Specialties class in the Network Analyst window.
The Properties window for the new specialty opens.
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2. In the Properties window, enter Wheelchair as the value of Name.

3. Click OK.

Adding orders

A spreadsheet is provided with the tutorial data. It contains information about each patient, including their
name and home address; the name and the address of the hospital they must be taken to; the time
window within which the patient has to be picked up; and so on. The following table describes the fields in
the spreadsheet:

Attribute Description

OrderName1 The name of the patient needing transportation

PatientAddress The location where the patient will be picked up

OrderName2 A unique name for the destination

HospitalAddress The location where the patient has the appointment

PickFrom The earliest time the patient may be picked up from PatientAddress

PickTo The latest time the patient may be picked up from PatientAddress

TotalPassengers The total number of passengers to be picked up

MaxTransitTime The maximum time the patient can spend in the van

SpecialtyNames Specifies the special needs that are required by the passenger, for example, a wheelchair

In this case, the passengers and hospital visits are related to each other since each passenger has to visit
a predetermined hospital. You can model this situation with order pairs—by loading both patient and
hospital locations into the Orders network analysis class and relating them with new order pair objects.

In the following steps, you will geocode the patient and hospital addresses and load the resulting points as
orders.

Steps:

1. Click File > Add Data > Geocoding > Geocode Addresses.
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The Choose an Address Locator to use dialog box opens.

2. Click SanFranciscoLocator.
The SanFranciscoLocator is included with Exercise08.mxd.

3. Click OK.
The Geocode Addresses: SanFranciscoLocator dialog box opens.

4. Click the browse button next to the Address table drop-down list.
The Choose a table containing addresses dialog box opens.

5. Click the Look in drop-down list and choose Home - Tutorial.
The table that you will add is stored in an Excel spreadsheet that is included in the ArcGIS
Network Analyst tutorial data.

6. Double-click OrderPairs.xls.

7. Double-click Patients$.
The Patients worksheet is added to the Address table drop-down list.

8. In the Street or Intersection drop-down list, choose PatientAddress.

9. Click the browse button next to the Output shapefile or feature class text box.
The Saving Data dialog box opens at the home location for Exercise08.mxd.

10. Click the Look in drop-down list and choose Home - Tutorial.

11. Click the Save as type drop-down list and choose File and Personal Geodatabase feature
classes.
The list of files and workspaces is updated.

12. Double-click SanFrancisco.gdb.

13. Delete the name in the Name text box and type Patients.
Patients will be the name of the output feature class.

14. Click Save.
The Output shapefile or feature class text box on the Geocode Addresses:
SanFranciscoLocator dialog box is updated to show the new output path.
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15. Click OK.
The Geocoding Addresses dialog box opens and indicates that all 15 addresses were
matched.

16. Click Close.
The geocoded addresses are added to the map document as a point feature layer,
Geocoding Result: Patients.

17. Repeat steps 1–16 to load the patients' destination hospitals, but make the following changes:
a. In step 8, set Street or Intersection to HospitalAddress.

b. In step 13, type DestinationHospitals in the Name text box.

The Table of Contents window should now have two feature layers, Geocoding
Results: DestinationHospitals and Geocoding Results: Patients.
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18. In the Table Of Contents window, uncheck the two geocoding results layers so that they are
not visible in the map display.

In the next steps, you will load these layers into the Orders network analysis class.

19. In the Network Analyst window, right-click Orders (0) and choose Load Locations.
The Load Locations dialog box opens.

20. Choose Geocoding Results: Patients from the Load From drop-down list.

The Location Analysis Properties section on the Load Locations dialog box lets you specify
which attributes of the Geocoding Results: Patients layer contain the values that Network
Analyst will reference in this vehicle routing problem.

21. Configure the properties that are listed in the Location Analysis Properties section so that
they copy field values from the Geocoding Results: Patients layer in the way specified by the
substeps below. (The next graphic highlights these changes.)

a. Map the Name property to the OrderName1 field.

b. Map the Description property to the PatientAddress field.

c. Map the TimeWindowStart1 property to the PickFrom field.

d. Map the TimeWindowEnd1 property to the PickTo field.

e. Map the PickupQuantities property to the TotalPassengers field.

f. Make sure that the SpecialtyNames property is automatically matched to the
SpecialtyNames field.

22. Type 2 under Default Value for the ServiceTime property.
All patient address locations that are loaded will have a ServiceTime value of 2 to account for
the average time (in minutes) that is taken for passengers to board the van.

23. Type 0 under Default Value for the MaxViolationTime1 property.
By setting all the MaxViolationTime1 properties to zero, the VRP solver will only search for
routes that visit the orders within their time windows.
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24. Click OK.
Fifteen orders are loaded. You can see them in the map display and in the Network Analyst
window.

In the next steps, you will load the destination hospitals as orders too.

25. In the Network Analyst window, right-click Orders (15) and choose Load Locations.
The Load Locations dialog box opens.

26. Choose Geocoding Results: DestinationHospitals from the Load From drop-down list.

27. Configure the properties that are listed in the Location Analysis Properties section so that
they copy field values from the Geocoding Results: DestinationHospitals layer in the way
specified by the substeps below. (The next graphic highlights these changes.)

a. Map the Name property to the OrderName2 field.
Note that the value for the Name attribute has to be unique in the Orders network
analysis class. In this case, there are many patients who need to visit the same
hospital. So if the hospital addresses were used to derive the value of the Name
attribute for Orders, then the VRP solver would return error messages as there would
be duplicate Name values.

b. Map the Description property to the HospitalAddress field.

c. Map the DeliveryQuantities property to the TotalPassengers field.
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d. Make sure that the SpecialtyNames property is automatically matched to the
SpecialtyNames field.

28. Type 2 under Default Value for the ServiceTime property.

29. Click OK.
Thirty orders are listed in the Network Analyst window under the Orders network analysis
class and are displayed as orders on the map in the Vehicle Routing Problem layer.

Adding order pairs

The passengers have to be taken to a predetermined hospital. By adding objects to the Order Pairs
network analysis class, you can add the information that specifies which hospital the patients have to be
taken to and the maximum time the patients can sit in the van during a one-way trip.

Steps:

1. In the Network Analyst window, right-click Order Pairs (0) and choose Load Locations.
The Load Locations dialog box opens.

2. Click the browse button next to the Load From drop-down list.

3. Click the Look in drop-down list and choose Home - Tutorial.
The table that you will add is stored in an Excel spreadsheet that is included in the Network
Analyst tutorial data.

4. Double-click OrderPairs.xls.

5. Double-click Patients$.
The Patients table is added to the Load From drop-down list on the Load Locations dialog
box.

6. Configure the properties that are listed in the Location Analysis Properties section so that
they pull field values from the Patients$ table in the way specified by the substeps below.
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a. Map the FirstOrderName property to the OrderName1 field.

b. Map the SecondOrderName property to the OrderName2 field.

c. Make sure that the MaxTransitTime property is automatically matched to the
MaxTransitTime field.

7. Click OK.
Fifteen order pairs are listed in the Network Analyst window under the Order Pairs network
analysis class.

Adding depots

The logistics company operates vans from three depots whose locations are shown in the CentralDepots
feature layer in ArcMap. You will now add these point features to the Depots network analysis class.

Steps:

1. In the Network Analyst window, right-click Depots (0) and choose Load Locations.
The Load Locations dialog box opens.

2. Select CentralDepots from the Load From drop-down list.

3. In the Location Analysis Properties section, make sure that the Name property is
automatically matched to the Name field.
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4. Click OK.
Three depots are listed in the Network Analyst window under the Depots network analysis
class and are displayed on the map in the Vehicle Routing Problem layer.

Adding routes

The logistics company has three vans, each with a maximum capacity of six passengers. The vans start
and return to the depots after completing all the trips. One of the vans that operates within the downtown
area has a lift to provide easy access for wheelchairs.

You will add three routes (one for each van) and set the property for the downtown van to include
Wheelchair as a specialty.

Steps:

1. In the Network Analyst window, right-click Routes (0) and choose Add Item.

A new route, Item1, is added under the Routes network analysis class, and the route's
Properties window opens.

2. In the Properties window, specify the attributes for the route as shown in the table below,
leaving the default values for the other attributes. The Description column in the table explains
the use of particular values.

Attribute Value Description

Name Downtown Name of the route.

StartDepotName Downtown Depot The van starts at the depot in the
downtown area.

EndDepotName Downtown Depot The van returns to the depot in the
downtown area at the end of the route.

Capacities 6 The van can carry a maximum of six
passengers at a time.

SpecialtyNames Wheelchair (Check
Wheelchair to set it as the
value.)

The van is equipped to provide access for
wheelchairs.
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3. Click OK.
A new route, Downtown, is listed in the Network Analyst window.

4. Repeat steps 1–3 to add two more routes representing the vans that operate in the North Bay
and East Bay areas. Use the following tables for these new routes instead of the properties
listed in step 2.

Attribute Value

Name North Bay
StartDepotName North Bay Depot
EndDepotName North Bay Depot
Capacities 6

Attribute Value

Name East Bay
StartDepotName East Bay Depot
EndDepotName East Bay Depot
Capacities 6

Note that these vans are not equipped to allow access for wheelchairs.

The Network Analyst window displays three route objects listed within the Routes network
analysis class.
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Adding route zones

The three vans used by the company are only licensed to service orders in a predetermined area. You will
add route zones and associate them with the vans/routes.

Steps:

1. In the Network Analyst window, select Route Zones (0).

2. Click the Create Network Location Tool on the Network Analyst toolbar.

3. On the map display, digitize a polygon that roughly covers the downtown area as shown
below.
Click to add vertices; double-click to complete the polygon.

A new route zone, Graphic Pick 1, is added to the route zones class in the Network Analyst
window.

4. In the Network Analyst window, double-click the new route zone object, Graphic Pick 1.
The route zone's Properties window opens.

5. Set the properties of the route zone as shown in the table below.

Attribute Value Description

RouteName Downtown The name of the route that this route zone is associated with.

IsHardZone True The van can't service orders that are outside the route zone.
Setting this value to True ensures that the van is only assigned
orders that are within the route zone.
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6. Repeat steps 1–6 to add two more route zones: one for the North Bay and one for the East
Bay.
The map and the Network Analyst window should contain three route zone objects.

Setting up the properties for analysis

Next you will specify the properties for your vehicle routing problem analysis.

Steps:

1. Click the Analysis Layer Properties button on the Network Analyst window.

The Layer Properties dialog box opens.

2. Click the Analysis Settings tab.
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3. Make sure that the Time Attribute drop-down list is set to TravelTime (Minutes).
The VRP solver will use this attribute to calculate time-based costs between orders and
depots.

4. Make sure that nothing is selected in the Distance Attribute drop-down list.
Since you are not using any distance-based cost parameters, such as CostPerUnitDistance or
MaxTotalDistance, setting the distance attribute is not required.

5. Set the Default Date to Day of Week. In the Day of Week drop-down list, choose Monday.

6. Since the van capacity is measured only by the total number of passengers that can be
accommodated, make sure that Capacity Count is set to 1.
If the capacity had been measured by the total number of passengers and the maximum
number of wheelchairs that can be accommodated in the van, the capacity count would be 2.

7. Leave the default options for the other properties.

8. Click OK.

Run the process to determine the solution

Steps:

1. Click the Solve button on the Network Analyst toolbar.
The VRP solver calculates the routes for each van. Each route begins at a depot, picks up one
or more people if the time they spend on the van is less than the MaxTransitTime specified in
the order pair, drops them at their hospital locations, continues to pick up and drop off other
people, and returns to the depot at the end. The routes only service orders in their assigned
route zones.
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Determine turn-by-turn directions for the routes

Steps:

1. Click the Directions Window button on the Network Analyst toolbar.
The Directions dialog box opens.

2. You can optionally export the vehicle routing problem as a layer file (<filename>.lyr) on disk so
that you can load it in a different map document.

3. Exit ArcMap without saving any changes.
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Exercise 9: Choosing optimal store locations using
location-allocation
In this exercise, you will choose the store locations that would generate the
most business for a retail chain. The main objective is to locate stores close
to population centers, which provide demand for the stores. This objective is
based on the premise that people tend to shop more at nearby stores than at
those that are farther away. You will perform the location-allocation analysis
using three different problem types: maximize attendance, maximize market
share, and target market share. The differences among these problem types
will become apparent as you work through the exercise.

Preparing your display

Steps:

1. If you have Exercise09.mxd open in ArcMap, skip to step 6.

2. Start ArcMap by clicking Start > All Programs > ArcGIS > ArcMap 10.

3. On the ArcMap - Getting Started dialog box, click Existing Maps > Browse for more.

4. Browse to C:\ArcGIS\ArcTutor\Network Analyst\Tutorial.
This is the default installation location for the tutorial data.

5. Double-click Exercise09.mxd.
The map document opens in ArcMap.

6. Enable the Network Analyst extension.
a. Click Customize > Extensions.

The Extensions dialog box opens.

b. Check Network Analyst.

c. Click Close.

If the Network Analyst toolbar is not displayed, you need to add it.

7. Click Customize > Toolbars > Network Analyst.
The Network Analyst toolbar is added to ArcMap.

If the Network Analyst window is not displayed, you need to add it.

8. On the Network Analyst toolbar, click the Show/Hide Network Analyst Window button .
The dockable Network Analyst window opens.

Complexity:
Beginner

Data Requirement:
ArcGIS Tutorial Data Setup

Data Path:
C:\ArcGIS\ArcTutor\Network
Analyst\Tutorial

Goal:
Choose store locations using a location-
allocation analysis.
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You can dock or undock the Network Analyst window. In this exercise, it is docked below the
Table Of Contents window.

Creating the location-allocation analysis layer

Steps:

1. Click Network Analyst on the Network Analyst toolbar and click New Location-Allocation.

The location-allocation analysis layer is added to the Network Analyst window. The network
analysis classes (Facilities, Demand Points, Lines, Point Barriers, Line Barriers, and Polygon
Barriers) are empty.
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The analysis layer is also added to the Table Of Contents window.

Adding candidate facilities

You will add the candidate store locations to the network analysis class Facilities. These are the potential
places where you can open a store. The solution from the location-allocation process will include a subset
of these stores.

The candidate store locations are already added as a layer (CandidateStores) in the map document. The
names of the stores are contained in the layer's attribute table. You will load the point features from
CandidateStores into the Facilities class of the location-allocation layer.

Steps:

1. In the Network Analyst window, right-click Facilities (0) and choose Load Locations.
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The Load Locations dialog box opens.

2. Select CandidateStores from the Load Locations drop-down list.

The Location Analysis Properties section of the Load Locations dialog box lets you specify
which attributes of the CandidateStores feature class contain the values that Network Analyst
will use to solve this location-allocation problem.

3. In the Location Analysis Properties section, make sure the Name property is automatically
mapped to the NAME field.

Network Analyst tries to match location analysis properties automatically for a newly created
location-allocation layer based on a configuration file (usually located in C:\Program
Files\ArcGIS\Desktop10.0\NetworkAnalyst\NetworkConfigurations\NASolverConfiguration.xml).

4. Click OK.
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Sixteen candidate stores are loaded into the Facilities network analysis class. The new
facilities are listed in the Network Analyst window and displayed on the map.

Adding Demand Points

The stores need to be located to best service the existing populations. A point layer of census tract
centroids is already added to ArcMap. Now you will load these centroids into the demand points network
analysis class.

Steps:

1. In the Network Analyst window, right-click Demand Points (0) and choose Load Locations.

2. Select TractCentroids from the Load Locations drop-down list.

3. In the Location Analysis Properties section, make sure the Name property is automatically
mapped to the NAME field.

4. Click the Field column for the Weight property and choose POP2000.
Each demand point will be weighted by the population from the 2000 census.

5. Click OK.
The 208 census tract centroids are loaded into the Demand Points class. The new demand
points are listed in the Network Analyst window and displayed on the map.
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Setting up the properties of the location-allocation analysis

Steps:

1. Click the Analysis Layer Properties button on the Network Analyst window.

The Layer Properties dialog box opens.

2. Click the Analysis Settings tab.

3. Make sure that Impedance is set to TravelTime (Minutes).

4. Set Travel From to Demand to Facility.
The default option, Facility to Demand, is a good choice for the classic minimize impedance
and maximize coverage problem types. However, for maximize attendance, maximize market
share, and target market share, the demand tends to travel to the facilities, thus Demand to
Facility is often a good choice for them.

5. Click the U-Turns at Junctions drop-down arrow and choose Allowed.

6. Set Output Shape Type to Straight Line.
Although the output will be displayed with straight lines, the travel costs are still measured
along the network.

7. Make sure that the Use Hierarchy and Ignore Invalid Locations boxes are checked.

8. In the Restrictions frame, make sure that RestrictedTurns and Oneway are checked.

Your Analysis Settings tab should look like the following graphic:
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9. Click the Advanced Settings tab.

10. Click the Problem Type drop-down list and choose Maximize Attendance.
These problem types are often referred to as models. Maximize attendance is a good problem
type for choosing retail store locations, since it assumes that all stores are equally attractive
and people are more likely to shop at nearby stores.

11. Increase Facilities To Choose to 3.
ArcGIS will try to choose 3 facilities out of the 16 to optimally serve the 208 demand points.

12. Increase Impedance Cutoff to 5.
This setting implies that people are not willing to travel more than five minutes to shop at these
stores. The units for this value are determined by the units of the impedance attribute.
Therefore, since TravelTime uses minutes, this value is also in minutes.

13. Make sure that Impedance Transformation is set to Linear. ArcGIS will use a linear decay in
calculating people's propensity to visit a store. That is, with a five-minute impedance cutoff and
a linear impedance transformation, the probability of visiting a store decays at 1/5, or 20
percent; therefore, a store one minute away from a demand point has an 80 percent probability
of a visit compared to a store four minutes away, which only has a 20 percent probability.

14. Click OK.
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Run the process to determine the best store locations

Steps:

1. Click the Solve button on the Network Analyst toolbar.
Once the solve process is completed, lines in the map display connect chosen stores to their
associated demand points. The lines also appear in the Lines class in the Network Analyst
window.

Now you will inspect the results in more detail.

2. In the Table Of Contents, right-click the Facilities sublayer and choose Open Attribute
Table.

Examine the attributes of the Facilities table. Three of the features have their FacilityType field
values set to Chosen instead of the default status, Candidate.

The DemandCount column lists the number of demand points assigned to each of the chosen
facilities. Note that out of the 208 demand points, only 113 were allocated to the chosen
facilities because some of the points were farther than the five-minute cutoff.

The DemandWeight column lists the demand that is allocated to each facility. In this case, the
value represents the number of people that are likely to shop at the store.

3. Close the Facilities table.

4. In the Table Of Contents, right-click the Demand Points sublayer and choose Open
Attribute Table.
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Examine the attributes of the Demand Points table. The Facility ID column has a value of <Null>
if the demand point was outside the five-minute cutoff, but if a numeric value is present, it
represents the ID of the chosen facility the demand point was allocated to.

The Weight column contains the population count that was loaded from the census tract feature
class. The AllocatedWeight column contains the amount of demand that was apportioned to the
associated facility. The amount of weight allocated is based on the linear distance decay and
the five-minute cutoff parameters you set in the Layer Properties dialog box.

5. In the Table Of Contents, right-click the Lines sublayer and choose Open Attribute Table.

This table contains one record for each demand point allocated to a facility. It also lists the
shortest path impedance between the two locations and the weight captured by the facility.

Adding a required facility

In the previous section, you generated results for where to locate three new stores. In this section, you will
use location-allocation to solve a store-expansion scenario, in which you will start with an existing store
and optimally locate two additional stores.

Steps:

1. In the Network Analyst window, right-click Facilities (16) and choose Load Locations.
The Load Locations dialog box opens.

2. Select ExistingStore from the Load From drop-down list.

3. In the Location Analysis Properties section, make sure that the Name property is
automatically matched to the NAME field.

4. In the Default Value column for Facility Type, change Candidate to Required.
This ensures that when the store is loaded as a facility, it will have a status of Required.
Required facilities must always be part of the solution.
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5. Click OK.

Setting up the properties of the analysis (maximize attendance with required facility)

You will use the same properties from the previous solution to solve this problem.

Steps:

1. Click the Analysis Layer Properties button on the Network Analyst window.

The Layer Properties dialog box opens.

2. Make sure that the problem type is set to Maximize Attendance, the facilities to find is 3, the
impedance cutoff is 5, and the impedance transformation is Linear.

3. Click OK.

Run the process to determine the best store locations (maximize attendance with
required facility)

Steps:

1. Click the Solve button on the Network Analyst toolbar.
When the solve process is complete, lines connect chosen stores to demand points. Note that
the original solution changed, and the ExistingStore location is now part of the solution. The
other two chosen facility locations are now at different places.
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Adding competing facilities

Location-allocation can locate new stores to maximize market share in light of competing stores. The
market share is computed using a Huff, or gravity, model. A Huff model assumes that demand points have
a probability of visiting stores based on some properties of the store as well as the distance away from
that store.

Steps:

1. In the Network Analyst window, right-click Facilities (17) and choose Load Locations.

2. Choose CompetitorStores in the Load From drop-down list.

3. In the Location Analysis Properties section, make sure that the Name property is
automatically matched to the NAME field.

4. In the Default Value column for Facility Type, change Candidate to Competitor.

5. Click OK.
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Setting up the properties of the analysis (maximize market share)

You will change the properties of the location-allocation analysis layer so that it solves using the maximize
market share problem type.

Steps:

1. Click the Analysis Layer Properties button on the Network Analyst window.

The Layer Properties dialog box opens.

2. Click the Advanced Settings tab.

3. Click the Problem Type drop-down list and choose Maximize Market Share.

4. Click the Impedance Transformation drop-down list and choose Power.
ArcGIS will use a power distance decay in determining people's propensity to visit a store.
Notice that Impedance Parameter becomes available for you to edit.

5. Change the Impedance Parameter value to 2.
An impedance parameter of 2 on a power impedance transformation means the probability of
visiting a store decays with the square of the distance between a demand point and a facility
location. Usually, an accurate value of the impedance parameter is computed from other
analyses, such as those provided by using ArcGIS Business Analyst.

The Advanced Settings tab should look like the following graphic:
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6. Click OK.

Run the process to determine the best store locations (maximize market share)

Steps:

1. Click Network Analyst on the Network Analyst toolbar and click Options.
The Network Analyst Options dialog box opens.

2. Click the General tab.

3. Click All Messages.
By choosing All Messages with a market share problem, the market share you capture will be
reported in a dialog box once the solve process is completed.

4. Click OK.

5. Click the Solve button on the Network Analyst toolbar.
When the solve process is completed, a message indicates how much of the market share you
captured.

6. Close the message box.

Lines in the map connect demand points to chosen and competitor stores. Notice the chosen
stores have changed to maximize the amount of demand given the presence of the three
competitors.

The lines overlap more than in the previous solutions, since each demand point in the maximize
market share problem can interact with all the facilities that are within the impedance cutoff.

7. In the Table Of Contents, right click the Facilities sublayer and choose Open Attribute
Table.

Three facilities have a FacilityType value of Competitor, one has a value of Required, and two
have a value of Chosen, which indicates the solver chose them as the best facilities to open.
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The DemandCount column lists the number of demand points assigned to each of the facilities.
Note that some demand points were not assigned, since they were outside the five-minute
cutoff.

The DemandWeight column lists the sum of the demand weight assigned to each of the chosen
facilities. The weight assigned to your stores versus that assigned to the competitor stores can
be used to figure out the market share that was reported after the solve process finished.

Achieving a target market share

In the last section, the three stores chosen accounted for 33.79 percent of the market share. Say,
however, you want to capture 70 percent of the market share. You need to know the minimum number of
stores that would be needed, and where they should be located, to accomplish that goal. The target
market share problem type can help you find the answer.

Steps:

1. Click the Analysis Layer Properties button on the Network Analyst window.

The Layer Properties dialog box opens.

2. Click the Advanced Settings tab.

3. Click the Problem Type drop-down list and choose Target Market Share.
Notice that when you change the problem type to Target Market Share, the Target Market
Share (%) property becomes available for you to edit.

4. Change Target Market Share (%) to 70.

The Advanced Settings tab should look like the following graphic:
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5. Click OK.

Run the process to determine the best store locations (target market share)

Steps:

1. Click the Solve button on the Network Analyst toolbar.
When the solve process is complete, a message indicates how much of the market share you
captured and the total number of facilities required to capture that share. The percentage is
more than the 70 percent you had indicated, because opening any fewer facilities would result
in a market share below your target of 70 percent.

2. Close the message box.

Once again, lines connect the solution facilities to demand points in the map display.

3. In the Table Of Contents, right-click the Facilities sublayer and choose Open Attribute
Table.

In addition to the three competitor facilities and the one required facility, nine facilities now have
a FacilityType value of Chosen. This means nine additional stores are needed to achieve the 70
percent market share.

4. If you don't plan to work on any other exercise, exit ArcMap. Click No to discard any changes.

5. If you plan to work on another exercise, follow the substeps below.
a. Click File > New.

The New Document dialog box opens.

b. Click OK.

c. Click No when prompted to save changes.
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